Windows 7 - Confronto colonne automatico

Asked By Max on 10-Aug-12 07:08 PM
Buona sera a tutti, sto cercando di creare una lista di controllo dopo
l'importazione di un file di testo in un foglio excel e dovrei far
evidenziare le celle che sono presenti in una colonna ma non nell'altra,
mi spiego meglio...

Nella colonna "A" ho una serie di celle con dei dati dentro, nella
colonna "B" incollo un elenco di dati che provengono da fonte esterna,
avrei bisogno di confrontare il contenuto delle due colonne e che mi
venisse evidenziato quali celle non sono presenti in una o nell'altra
colonna.
Questo per capire quali sono i nuovi articoli inseriti (dal file
importato e incollati nella colonna B) o quelli che sono andati in
esaurimento (dal vecchio elenco nella colonna A) che saranno da togliere.

In questo momento lo faccio manualmente, confronto le due colonne e se
trovo un nuovo articolo nella B, nella colonna A lascio una spazio per
la cella e sposto i dati in basso di una riga e viceversa per gli obsoleti.
Finito il controllo, copio il contenuto della colonna B sulla colonna A
e cancello la B che utilizzer? al controllo successivo.

E' fattibile un controllo del genere ??
Se fosse fattibile, ? possibile che il confronto lo faccia solo per le
prime 15/20 lettere del testo che trova scritto all'interno delle colonne ?

So che sono stato contorto, chiedete pure delucidazioni se necessarie.

Ciao
Max




Andrea.9 replied to Max on 11-Aug-12 10:18 AM
per evidenziare le celle non presenti nell'altro elenco usa la
formattazione condizionale con le seguenti formule:
per la colonna A questa:
=CONTA.SE($B$1:$B$7;A1)=0
per la colonna B questa:
=CONTA.SE($A$1:$A$7;B1)=0
fai sapere
ciao
andrea
Andrea.9 replied to Max on 11-Aug-12 10:37 AM
per prendere in considerazione solo le prime lettere della stringa mi
sono venute queste.
sono sempre da utilizzare con la formattazione condizionale.
se le usi esternamente in una cella tieni conto che in realta' sono
matriciali e quindi da inserire con Ctrl+Shift+Invio
per la colonna A questa:
=VAL.ERRORE(CONFRONTA(SINISTRA(A1;15);SINISTRA($B$1:$B$7;15);0))
per la colonna B questa:
=VAL.ERRORE(CONFRONTA(SINISTRA(B1;15);SINISTRA($A$1:$A$7;15);0))
se vuoi i primi 20 caratteri sostituisci 20 ai 15 o usa un
collegamento ad una cella
fai sapere
ciao
andrea
Max replied to Andrea.9 on 12-Aug-12 04:22 AM
Il 11/08/2012 16:37, Andrea.9 ha scritto:
Perfetto, ho solo modificato il range di celle della colonna $B$1:$B$7
in $B$1:$B$1000 per prendere in analisi tutti i dati presenti e futuri,
lo stesso ovviamente per la seconda formula.

Grazie
Max
Andrea.9 replied to Max on 13-Aug-12 08:37 AM
Grazie a te per il riscontro
Ciao
Andrea