Windows 7 - Comment créer_une_formule_de_calcule_de_moyennes_de_fréquence_de_classe_?

Asked By ®omain on 12-Aug-12 12:26 PM
Bonjour,

J'ai un tableau d'?chantillons r?partit par fr?quences cumul?es dans 23
classes d?croissantes.

Comment cr?er une formule qui recueille elle m?me les classes et les
effectifs plut?t que de tout entrer dans une grande formule ?

Lien du fichier Excel : http://cjoint.com/?BHmr6hj2JdX

Par exemple l'?chantillon n?12 : 16,6 % mesure entre 8000 et 6300,
(28,8-16,6)= 12,2 % mesure entre 6300 et 5000, et etc.
On calcule que 16,6 % mesure en moyenne (8000+6300)/2= 7150, 12,2 %
mesure en moyenne (6300+5000)/2= 5650, etc.
On multiplie les effectifs par la moyenne leur taille de classe
16.6?7150=118690, 12,2?5650=68320, etc.
On additionne les produits effectifs ? moyenne de leurs classes 118690 +
68320 + etc. que l'on divise par l'effectif total (100 si %) ce qui
donne la Moyenne.

Je pourrais faire une formule avec les 23 classes, ce n'est pas ?norme.
Mais j'ai un autre tableau de 140 classes qui m'attend, alors une
formule qui ferait toutes les ?tapes que j'ai ?crit au dessus pour
chaque classe serait super.

Je vous remercie d'avance de tout conseil qui me guiderait.

?+
RP




h2so4 replied to ®omain on 12-Aug-12 06:00 PM
?omain laid this down on his screen :

bonjour,

pour r?soudre ton probl?me

1) utiliser massivement la copie de formule
2) cr?er les donn?es interm?diaires qui te permettront de faire tes
calculs

par exemple

creer une feuille suppl?mentaire qui calcule la fr?quence de chaque
classe (feuille dc) en f8


=%_surf_2012!F8-%_surf_2012!E8

une fois la formule introduite, la copier  en tirangt vers la droite
140 fois (colonne EK), puis tirer vers la bas autant de fois que
n?cessaire

creer une feuille suppl?mentaire qui calcule fr?quence * taille moyenne
de la classe (TM) en F8

=dc!F8*(%_surf_2012!E$1+%_surf_2012!F$1)/2

une fois la formule introduite, tirer vers la droite 140 fois,

rajouter le calcul pour la moyenne pond?r?es des classes

en A8 =SOMME(F8:EK8)/100

tirer toute la ligne 8 vers la bas.

bonne chance



--
h2so4
ca PAN
pique DORA
.
®omain replied to h2so4 on 13-Aug-12 06:19 AM
???,
Oui, les formules interm??diaire c'est plus facile ?? faire qu'une seule
formule que je ne sais pas faire.
Merci,
??

h2so4 a ??crit :
gmlstep replied to ®omain on 13-Aug-12 07:03 AM
Bonjour,=20
Si j'ai bien compris...faut juste rep=E9rer la derni=E8re cellule...
A l'identique du cadre  la feuille2 pour 23 colonnes on en fera pas plus qu=
e ces 5 secondes de manip pour davantage  de colonnes:

S=E9lectionner plus globalement f2:aa42   (F5-aa72-Shift+Ok)-puis F2

Entrer
=3DSI(Brute_surf_2012!F2=3D"";"";(Brute_surf_2012!F2/Brute_surf_2012!$AA2*1=
00)*(E$1+F$1)/2)
=E0 valider Ctrl+Entr=E9e tu obtiens tous tes effectifs par classe
plus qu'=E0 ajouter ta moyenne en derni=E8re colonne.=20

http://cjoint.com/?BHnncE01qqL=20

Sinon mets  un exemple de ce que tu veux obtenir.
--
LSteph


Le dimanche 12 ao=FBt 2012 18:26:42 UTC+2, =AEomain a =E9crit=A0:
ences cumul=EF=BF=BDes dans 23=20
sses et les=20
et 6300,=20
18690 +=20
norme.
ssus pour=20
®omain replied to gmlstep on 13-Aug-12 09:54 AM
Bonjour,
Merci votre id?e est pratique et simple : qu'une seule ?tape
interm?diaire et une formules de quelques op?rations seulement.
Je crois que comme j'ai des effectifs cumul?s je dois ajouter une
soustraction :
=SI(Brute_surf_2012!F2="";"";((Brute_surf_2012!F2-Brute_surf_2012!E2)/Brute_surf_2012!$AA2)*(E$1+F$1)/2)
Je crois que le ?100 est de trop.
Je crois qu'? la fin faut faire SOMME des r?sultats trouver avec la
pr?c?dente formule =SI(AA8<>"";SOMME(F8:AA8);"")
?+
?

http://cjoint.com/?BHnpZJ3jvQU

gmlsteph@gmail.com a ?crit :