Windows 7 - Remplisage en couleur avec =si()

Asked By Albert on 12-Aug-12 03:52 PM
Bonsoir ou bonjour

J'ai un fichier avec en colonne  A les Emails t en colonne B les noms.
Certains  n'ont pas de Email  alors la cellule est vide, d'autres partagent
leur Email avec leur conjoint ce qui cause des doublons.
Apr?s un tri ascendant, les Emails vides sont au d?but et facilement
supprim?s.
Je veux colorier seul le deuxi?me doublons pour le supprimer avec un filtre
couleur en utilisant la formule "SI" comme suit :
=SI(A2=A1;Remplissage A2 jaune ;"")
Cela est-il possible ?

Actuellement j'utiilise    =SI(A2=A1;"double";"")   et la MEFC
=c1="double" remplissage jaune.

Fichier exemple sur  http://cjoint.com/?BHmvZUUVGO3

Merci de vos suggestions.


--
albertri-at-videotron.ca.invalid




Jacquouille replied to Albert on 12-Aug-12 04:06 PM
Bonsoir Albert
Pourquoi ne filtres-tu pas "sur place" ou  sur une autre feuille, avec
l'option " sans doublon" ?



Jacquouille

k091ib$1ko$1@speranza.aioe.org...

Bonsoir ou bonjour

J'ai un fichier avec en colonne  A les Emails t en colonne B les noms.
Certains  n'ont pas de Email  alors la cellule est vide, d'autres partagent
leur Email avec leur conjoint ce qui cause des doublons.
Apr?s un tri ascendant, les Emails vides sont au d?but et facilement
supprim?s.
Je veux colorier seul le deuxi?me doublons pour le supprimer avec un filtre
couleur en utilisant la formule "SI" comme suit :
=SI(A2=A1;Remplissage A2 jaune ;"")
Cela est-il possible ?

Actuellement j'utiilise    =SI(A2=A1;"double";"")   et la MEFC
=c1="double" remplissage jaune.

Fichier exemple sur  http://cjoint.com/?BHmvZUUVGO3

Merci de vos suggestions.


--
albertri-at-videotron.ca.invalid
Albert replied to Jacquouille on 12-Aug-12 04:27 PM
Bonsoir Jaccquouille


Cest un possibilit?  ? laquelle je n'avais pas pens?, mais j'aimerais quand
m?me avoir un r?ponse ? ma question originale
est-ce possible de colorier une cellule avec la fonction "SI"
ou
est-ce possible de faire une MEFC  avec une fonction "SI"

Merci ? Jacquouille ton intervention est tr?s appr?ci?


--
albertri-at-videotron.ca.invalid
Jacquouille replied to Albert on 12-Aug-12 04:53 PM
Re
Je ne pense pas que l'on puisse colorier une cellule ? partir d'une fonction
Par contre, une MEFC ne demande que cela, puisque sa raison d'?tre est
Tu peux colorier la cellule C1 si A1 = B1
Coisir Format, MEFC, la formule est, $a1=$b1 .......> Ok


Jacquouille

k093j7$6ge$1@speranza.aioe.org...

Bonsoir Jaccquouille


Cest un possibilit?  ? laquelle je n'avais pas pens?, mais j'aimerais quand
m?me avoir un r?ponse ? ma question originale
est-ce possible de colorier une cellule avec la fonction "SI"
ou
est-ce possible de faire une MEFC  avec une fonction "SI"

Merci ? Jacquouille ton intervention est tr?s appr?ci?


--
albertri-at-videotron.ca.invalid
Albert replied to Jacquouille on 12-Aug-12 06:49 PM
Re bonsoir


Vous remarquerez que le ficher mentionn? dans http://cjoint.com/?BHmvZUUVGO3
utilise d?j? ces crit?res.
Mais je recherchais des crit?res plus complexes, mais c'est vrai que les
crit?res  utilis?s, c'est d?j? l'?quivalent de la fonction "SI".

Bonne nuit ou Bon matin

--
albertri-at-videotron.ca.invalid
MichD replied to Albert on 12-Aug-12 09:27 PM
Bonjour,

Une alternative,

Dans une colonne ? c?t?, tu peux utiliser cette formule : =NB.SI(A1:$A$535;A1)>1
que tu recopies sur l'ensemble de la colonne et tu filtres sur "Vrai" pour enlever
tous les doublons. (Premi?re occurrence du doublon)

Tu peux aussi utiliser la m?me formule pour une mise en forme conditionnelle.
Tu s?lectionnes toute la plage de cellule... et elle met en couleur les doublons
suivant la premi?re occurrence.



MichD
---------------------------------------------------------------
gmlstep replied to Albert on 13-Aug-12 05:58 AM
Bonjour,

MEFC ainsi sur toute ta colonne =20
=3DNB.SI($A$2:A2;A2)>1=20
ou bien en tierce colonne
=3DSI(NB.SI($A$2:A2;A2)>1;"doublon";"")

Ton fichier modifi=E9 http://cjoint.com/?BHnl5i2O7xb=20

'LSteph

Le dimanche 12 ao=FBt 2012 21:52:46 UTC+2, Albert a =E9crit=A0:
nt=20
=20
ltre=20
Jacquouille replied to Albert on 13-Aug-12 07:21 AM
Bonjour Albert,

Le c??ur a ses raisons que la raison ne connait point.
Avec une MEFC, il faudra quand m??me supprimer les doublons ?? la main .....
Chacun a ses exigences, ses choix et ses amours ....que je respecte.


Jacquouille

k09bsv$p1e$1@speranza.aioe.org...

Re bonsoir


Vous remarquerez que le ficher mentionn?? dans http://cjoint.com/?BHmvZUUVGO3
utilise d??j?? ces crit??res.
Mais je recherchais des crit??res plus complexes, mais c'est vrai que les
crit??res  utilis??s, c'est d??j?? l'??quivalent de la fonction "SI".

Bonne nuit ou Bon matin

--
albertri-at-videotron.ca.invalid
Albert replied to MichD on 13-Aug-12 09:00 AM
Bonjour
Merci ? vous trois, cela r?soud mon probl?me d'identifier les doublons, car
il est n?cessaire de les identifier avant de supprimer le moins important.
Merci beaucoup.

Albert