Windows 7 - Macro per trasferire e formattare dati

Asked By [oTTo] on 13-Aug-12 08:01 AM
Ciao a tutti,

Dovrei trasferire e formattare una serie di dati da un foglio ad
un'altro di un file di Excel e vorrei creare una macro che me lo faccia
in automatico.

In pratica ho i dati del "Foglio 1" che riguardano la produzione degli
operai (ossia il giorno, il mese, quanti pezzi hanno prodotto e quante
ore ci hanno impiegato) e vorrei trasferirli nel "Foglio 2" suddivisi
per mese, sommando le ore e sommando i pezzi prodotti ogni giorno da
ogni operaio (considerando che non tutti i giorni ho per forza tutti e 5
gli operai).

Chi mi da qualche dritta su come comporre la macro ?

Qui trovate il file di esempio: http://sharesend.com/yo263

Grazie, ciao.




plinius replied to [oTTo] on 13-Aug-12 03:39 PM
Il 13/08/2012 14:01, [oTTo] ha scritto:

Si pu? fare con formule, senza macro.

Definisci questo nome:
rng: =SCARTO(Foglio1!$A$2;;;CONTA.VALORI(Foglio1!$A:$A)-2;5)

Nelle celle di Foglio2 inserisci questa formula matriciale (da
confernare con CONTROL+MAIUSC+INVIO):
=SOMMA((INDICE(rng;;2)=D$1)*(INDICE(rng;;3)=TESTO(DATA(;(RIF.RIGA()-1)/11+1;1);"mmmm"))*(INDICE(rng;;1)=SCARTO($A2;SE($A2=0;-1;0);))*SE($A2=0;INDICE(rng;;4);ORARIO.VALORE(SOSTITUISCI(TESTO(INDICE(rng;;5);"#0,00");",";":"))))

Qui ho caricato il foglio integrato in tal modo:
http://sharesend.com/5x4cw

Ciao,
E.
[oTTo] replied to plinius on 13-Aug-12 04:58 PM
Perfetto ! grazie davvero.

Ciao